
Cumulus Main Window  

The main window in Cumulus displays all the current weather data, updated as it is received 

from the weather station. The heading on this page is configurable by selecting Display from 

the Configuration menu.  

The wind speed indicator shows three values: 

� The needle shows the current snapshot of the wind 

speed, as read from the weather station.  What this 

figure represents exactly, depends on the type of 

weather station - in general it is the latest "short-

term" speed and corresponds to the 'Latest' figure on 

the Cumulus display.  

� The green arc shows the current average wind speed. 

It corresponds to the 'Average' figure on the Cumulus 

display.  

� The red arc shows the recent highest gust (in the last 

ten minutes). It corresponds to the 'Gust' figure on the 

Cumulus display.  

See below for further information about wind speeds. 

  

  

  

  

The wind direction indicator shows the current snapshot of 

the wind direction, as read from the weather station, with a 

red pointer (also indicated by the bearing in the centre of the 

gauge); it also shows the average wind direction over the 

last ten minutes, with a blue pointer. 

  

  

  

  

  

The third indicator gives a visual summary of the relative 

wind strength and direction over last few hours; the lines 

drawn in each direction take into account the strength of the 

wind as well as the length of time it has been coming from 

that direction. 
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The 'New Record' light will flash when any of the all time records has been broken. Clicking 

on the light will open the All Time Records display. 

The 'Error' light will flash when an error has occurred, usually when updating your web site. 

Clicking on the light will open a window showing the most recent errors. Usually this is nothing 

to worry about, you can expect to get an upload error from time to time. 

For Davis users, the status of the transmitter batteries is given at the bottom left of the main 

window. 

At the bottom right hand corner is a 'Current Conditions' text box, whixh is invisible until turned 

on with the option in the display settings. A description of the current conditions can be entered 

here, and the web tag <#currcond> will be replaced by this text if used in a web page 

processed by Cumulus. If a file called 'currentconditions.txt' exists in the same directory as the 

Cumulus executable, the contents of this file will be used for the web tag instead. The file will 

be deleted if the text in the current conditions box is modified. 

The status bar, at the very bottom of the main window, displays various messages indicating 

when internet uploads are taking place, and at the right hand end of the status bar is displayed 

the number of entries downloaded from the logger the last time Cumulus was started, and the 

last time data was read from the station. 

A note about wind speeds: No two types of weather station provide exactly the same type of 

wind speed information. Weather stations typically supply two wind speed values; a short-term 

value (sometimes called 'gust' by the station) and a longer-term or average value (sometimes 

called 'average' by the station, or sometimes simply 'speed'). Some weather stations only 

supply a single wind speed value. Cumulus tries to fit all of the various values into three 

displayed items: 

� Latest: This is the latest reading of the 'short-term' speed.  

� Gust: This is the highest value in the last 10 minutes of the 'short-term' values.  

� Average: This is the longer-term or average value. Sometimes this is taken directly from 

the station, and sometime it is a 10-minute average calculated by Cumulus, depending 

on whether you have told Cumulus to do so in the station settings.  

Cumulus Menus  

Menu Item Function 

File   

  
Web 

Update
Causes an immediate update of the web site pages.

  Print Sends an image of the main window to the default printer. 

  Exit Causes Cumulus to close. 

 

Edit  

  
All time 

records 

Opens the "All Time Records Setup" screen which allows the all time records 

to be edited 

  Alarms
Displays the "Alarms" screen which allows you to set alarms for when 

various conditions occur. 

  
Copy to 

clipboard
Copies the current data to the clipboard

 

View   

  
Highs and 

Lows
All time  - Displays the "All Time Records"Window.

   Today  - Displays today's highs and lows

   Yesterday  - Displays yesterday's highs and lows

   This month  - Displays this month's highs and lows

   This year  - Displays this year's highs and lows
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The "All Time Records" Window  

This window can be displayed by either clicking on the Alarm light on the main window, or by 

selecting All time records from the View menu. The current records are shown; if any 

records have been broken since the last time the window was opened, the light next to that 

entry will be flashing. Clicking on the light will turn it off, and closing the window will turn off all 

the lights.  

  

The "This Month" Window  

This window can be displayed by selecting This Month from the View menu. Various statistics 

for the current month so far are displayed.  

Months other than the current month can be selected using the Month and Year selectors and 

then clicking Update display.  

The currently displayed data can be copied to the clipboard (so it can be posted into a Usenet 

article, for example) by clicking on Copy to clipboard.  

Note that the data that is displayed for the current month does not include data for the current 

day.  

  
This 

month
Displays the "This Month" summary window. 

  This year Displays the "This Year" summary window. 

  
This 

period
Displays the "This Period" summary window. 

  Graphs Displays the "Graphs" Window. 

  
Weather 

Diary
Displays the "Weather Diary" Window. 

  
Snow 

Index
Displays the "Eden Winter Snow Index". See here for an explanation.

  
Select-A-

Graph

Displays the "Select-A-Graph" Window, which allows you to display historical 

data as a graph. 

 

Configuration   

  Station
Opens the Station Settings window which allows details of the weather 

station and its location to be set. 

  Internet
Opens the Internet Settings window which allows details of the web site on 

which data from Cumulus is to be published to be set.

  Display
Opens the Display Settings window which allows the appearance of Cumulus 

to be configured. 

  
Debug 

Log 

Select this to turn on debug logging. Entries are made to the log for 

debugging purposes. A file is created in the Cumulus program folder called 

"debug.log".  Entries are flushed to this file every five minutes, or when the 

program closes. Note that this setting is not related to the logging of 

weather data. Please do not turn this on unless requested, and do not 

leave it turned on once the required diagnostics have been obtained. 

  
FTP 

Logging 

Select this to turn on ftp logging. Two files are created in the Cumulus 

program folder called "ftplog.txt" and "realtimeftplog.txt".

 

Help   

  
Help 

topics
Displays the Cumulus help file.

  About Displays information about Cumulus. 
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The "Graphs" Window  

This window can be displayed by selecting Graphs from the View menu.  

The data in the large graph is sampled every minute (apart from the Min/Max Temp and Daily 

Rainfall graphs, which are daily values), while the data in the smaller graphs is sampled every 

ten minutes. 

Right clicking on one of the larger graphs brings up a pop-up menu allowing you to change the 

colour used for plotting that graph. 

Clicking on one of the smaller graphs causes its larger version to appear in the large graph 

area. You can 'zoom' an area of the large graph by dragging with the mouse; to 'unzoom', drag 

from lower right to top left. Note that if you are uploading graph images to a web site, they will 

appear exactly as they are in Cumulus - i.e. if you have 'zoomed' them, that is how they will 

appear. 

 

  

The "Weather Diary" Window  

This window can be displayed by selecting Weather Diary from the View menu.  

The Weather Diary facility allows the user to enter some short notes (up to 1024 characters) for 

each day, and to record whether snow was falling and/or lying on that day, along with the 

depth of snow.  

To make an entry: 

Select the date on the calendar by clicking on it, then enter the required details. Click on update 

to save the entry.  

Clicking on Close closes the window and saves the entry to the log file. 

To update an existing entry: 

Select the date on the calendar by clicking on it, then amend the required details. Click on 

update to save the entry. 

Clicking on Close closes the window and saves the entry to the log file. 

  

The "Select-A-Graph" Screen 

This screen can be displayed by selecting Select-A-Graph from the View menu. The screen 

allows you to display historical data from the log files as a graph. Choose the items to be 

displayed by ticking the appropriate boxes, set the start and end dates and times, and click the 

'update' button to display the chosen graph. Note that some combinations of parameters may 

not produce nice results, as they all have to use the same Y-Axis scale.  

You can change the colour of the graph lines using the colour buttons, and change between a 

2D and 3D display with the 'Display 3D' checkbox. 

 The graph can be printed or saved as a PNG file from the corresponding items in the 'File' 

menu. 

You can click the 'Clear' button when you have finished with Select-A-Graph to clear the graphs 

and release the memory used (which can be considerable for large timespans). 
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The Records (Highs and Lows) Editors 

These can be accessed by selecting All time records, This month's records, or This year's 

records from the Edit menu.  

The current records are shown;  the values, dates and times can be changed by typing in the 

appropriate box. Clicking on 'Fetch log data' will cause a scan of all of your monthly log files to 

retrieve the highs and lows; these will then be displayed in the grid. Similarly, clicking on 'Fetch 

dayfile data' will cause a scan of the dayfile.txt file to retrieve the highs and lows from that file. 

You can copy either of the retrieved values (with their date and time) to the 'curren't value in 

the grid by clicking the appropriate 'copy' button. Clicking the 'reset' button will cause the 

existing record to appear again. 

Note that when fetching the highs and lows from the log files, this is very much a case of 

'garbage in, garbage out'. If you have any errors in your log files (caused by bad data, bugs in 

Cumulus now or at some time in the past, etc) these will appear in the grid, and you may find 

that you want to edit them from the log files before trying again. For some items, Cumulus may 

not be able to retrieve a value; this will usually be because it is not possible to determine that 

particular item from the log files (e.g. monthly rain totals cannot redaily be determined from 

the monthly log files, only from dayfile.txt). 

Important: Even if your data is 100% perfect, do not expect to see all of the retrieved 

values agreeing exactly. This is due to fact that the log files are 'snapshots' of the data, so 

may not actually have caught a particular high or low. The facility is simply there so that you 

can retrieve a good value to replace an existing record which may have been corrupted in some 

way. Also, because the list of data items (and highs and lows) logged by Cumulus has changed 

over the years, a particular record may not currently go back all the way to the beginning of 

your data, so you can use the scan of the log files to find a better value. For Apparent 

Temperature and Heat Index, which Cumulus has only relatively recently started recording, it 

will retrospectively calculate these values from the Temperature, Humidity, and Wind Speed 

values, for those older entries which don't contain the items themselves. 

When you are happy with all of the settings, click the OK button to save them. Alternatively, 

click the Cancel button to discard any changes. 

  

The "Alarms" Screen 

This screen can be displayed by selecting Alarms from the Edit menu. You can set an alarm 

for various conditions, e.g. the temperature falling below a particular value. Type the required 

value into the appropriate box, and tick the 'Alarm if...' box to set the alarm. You can also have 

a sound played when the alarm occurs by ticking the 'Play sound' box. A default sound is 

played, but clicking the 'Choose sound' button allows you to select a '.wav' file to be played for 

each alarm. 

When an alarm condition occurs, the label for the item causing the alarm goes red. If you click 

on the label, it goes black again and the alarm is reset. Note that it may occur again 

immediately. If you do not click on the label and the alarm condition ceases to exist (e.g. the 

temperature rises above the pre-set value) the label goes blue to show that an alarm condition 

has existed at some time. Again, clicking on the label turns it black and the alarm is reset. 
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